2014年8月29日

ntpcU藍芽無線與motoduino

使用新北市教育作業系統(基於ubutnu14.04)利用香菇頭藍芽和motoduino達成無線連接操作方法
1.安裝藍芽管理套件blueman,在軟體中心輸入blueman關鍵字,把它安裝起來。安裝完成在左側欄有圖示,常用的話把它鎖在dash上(滑鼠右鍵)。

2.插入香菇頭並在右上角啟動藍芽管理員/開啟藍芽(這時把motoduino接上外接電源和藍芽或是在旁邊一台電腦插上usb連接線),再點選搜尋附近裝置。 這時會找到一個linvor設備。


 

  




3.在這個設備上按下滑鼠右鍵/setup, 選擇配對方式/使用自訂密碼,輸入1234,按下一步。


4.選擇serial port,再按下一步,這時就會連線成功,右上角會出現連上rfcomm0,這個相當於windows下的com1。這時已連上藍芽。
 
5.為了讓使用者不用切換最高權限即可使用這個設備, rfcomm0這個設備是屬於dialout群組,請用vim編輯/etc/group這個檔案,找到diaout在:後面加上你想加的使用者,存檔。
vim /etc/group(這個做完要重開機)


6.啟動在dash中輸入s4a,這時候,你會發現,依然找不到設備,這是因為s4a在linux下預設會去找ttyUSB0,然而我們的藍芽卻是rfcmm0。如何解呢?


7.請開啟終端機貼上下列指令(做一個連結把rfcmm0連到ttyUSB0):
sudo ln -s /dev/rfcomm0 /dev/ttyUSB0

8.再開啟s4a,就會看到下圖,連線成功。
就可以利用無線來控制motoduino板子了。

注意:藍芽的傳輸速率要調成38400有些預設不是它也會造成連線成功但讀不出數值。



















2014年8月28日

文字轉語音程式

到一間學校,老師說:有特殊學生需要報讀軟體,查了一下ubuntu是否有相關軟體,結找到一個可能適用的軟體,把文字轉語音。在軟體中心的無障礙功能中有一個jovie程式,試用一下還不錯,可以中文發音。
安裝:

設定:








2014年8月25日

subline text3筆記1

展嘉老師教了jquery  bootstrap想把它好好記一下。
使用編輯器sublime text3
 要安裝的擴充套件:package control
https://sublime.wbond.net/installation
打開sublime後按下ctrl+`貼上下列內容
import urllib.request,os,hashlib; h = '7183a2d3e96f11eeadd761d777e62404' + 'e330c659d4bb41d3bdf022e94cab3cd0'; pf = 'Package Control.sublime-package'; ipp = sublime.installed_packages_path(); urllib.request.install_opener( urllib.request.build_opener( urllib.request.ProxyHandler()) ); by = urllib.request.urlopen( 'http://sublime.wbond.net/' + pf.replace(' ', '%20')).read(); dh = hashlib.sha256(by).hexdigest(); print('Error validating download (got %s instead of %s), please try manual install' % (dh, h)) if dh != h else open(os.path.join( ipp, pf), 'wb' ).write(by) 

在Preferences下就會出現package control,在Package install 中要安裝package有jquery bootstrap emmet

jquery網站
http://jquery.com/

bootstrap網站
http://getbootstrap.com/

好好學一下,把一些基本功練習一下。

2014年8月23日

canon LBP 5700印表機安裝

canon LBP 5700印表機的驅動程式,竟然在官網上都找不到,網路上其他載點也都怕怕的,同事電腦還原,找了好幾天在商業軟體上也都無解,在linux上也是如此,求神求了好久。今天找到解答了,原來linux這麼強,早收錄了,只是要知道用其他型號印表機。
根據:http://cweb.canon.jp/e-support/faq/answer/lbp/27987-1.html
canon LBP 5700要用的型號是: Canon LIPS4 Printer Driver for Linux
照著裝就裝好了,列印也正常。商軟體我找了好久都無解,最後找到一家公司在他們網站下也是要找其他型號的印表機才正常安裝起來。
新北市教育作業系統安裝canon LBP 5700問題已解決,比商軟體安裝印表機還快速免下載驅動程式。

2014年8月12日

chromium fash不能執行的原因

因為flash套件在firefox和chromium是不一樣的,何時改的不知。
解決方法
使用chromium開啟下列連結安裝flash套件

 
重新啟動chromium。